[Webkit-unassigned] [Bug 125083] Fix !ENABLE(JAVASCRIPT_DEBUGGER) build
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Dec 2 11:32:14 PST 2013
https://bugs.webkit.org/show_bug.cgi?id=125083
Mark Lam <mark.lam at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #218192|review? |review-
Flag| |
--- Comment #4 from Mark Lam <mark.lam at apple.com> 2013-12-02 11:30:36 PST ---
(From update of attachment 218192)
We can avoid adding all these #if ENABLE(JAVASCRIPT_DEBUGGER) if we just add a stub Debugger class in Debugger.h. Something like this:
#if ENABLE(JAVASCRIPT_DEBUGGER)
class JS_EXPORT_PRIVATE Debugger {
...
};
#else // ENABLE(JAVASCRIPT_DEBUGGER)
class Debugger {
public:
Debugger(bool = false) { }
... // More stubbed functions as needed.
};
#endif // ENABLE(JAVASCRIPT_DEBUGGER)
If done right, the performance and memory usage difference should be negligible (if at all), and the code would be more readable due to not having #ifs scattered in.
Can you please try that approach and submit another patch?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list