[Webkit-unassigned] [Bug 119938] Animate CSS Image filter() function

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 20 11:59:38 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=119938


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #209116|review?                     |review-
               Flag|                            |




--- Comment #16 from Simon Fraser (smfr) <simon.fraser at apple.com>  2013-08-20 11:59:05 PST ---
(From update of attachment 209116)
View in context: https://bugs.webkit.org/attachment.cgi?id=209116&action=review

> LayoutTests/fast/filter-image/filter-image-animation.html:58
> +    @-webkit-keyframes no-anim {
> +        from { background-image: -webkit-filter(url(resources/image.svg), sepia(1)); }
> +        to   { background-image: -webkit-filter(url(resources/blue.svg), sepia(0)); }
> +    }

You should test a blend between a filter and simple image, and a filter and gradient, and filter and crossfade (to check for code that behaves badly).

You should also test for blends between filter lists of the same and different lengths, and maybe with missing filter lists.

> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:903
> +static inline PassRefPtr<CSSPrimitiveValue> valueForPixel(double length, const RenderStyle* style, ZoomAdjustedPixel adjust)

This has a very confusing name; it sounds like you're lookup up the RGBA for a single pixel.

> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:908
> +static inline PassRefPtr<CSSPrimitiveValue> valueForPixel(const Length& length, const RenderStyle* style, ZoomAdjustedPixel adjust)

Ditto.

> Source/WebCore/css/CSSComputedStyleDeclaration.h:51
> +enum ZoomAdjustedPixel { AdjustPixel, DoNotAdjustPixel };

Enum types should be descriptive, like AdjustPixelVaulesForZoom { AdjustPixelValuesForZoom, DoNotAdjustPixelValues }

> Source/WebCore/css/CSSFilterImageValue.cpp:168
> +bool CSSFilterImageValue::equalInputImages(const CSSFilterImageValue& other) const

Much better than subimage!

> Source/WebCore/css/CSSFilterImageValue.h:49
> +

Blank line.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list