[Webkit-unassigned] [Bug 119785] Replace currentTime() with monotonicallyIncreasingTime() in WebCore

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 16 10:58:30 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=119785





--- Comment #14 from Jer Noble <jer.noble at apple.com>  2013-08-16 10:58:02 PST ---
(From update of attachment 208849)
View in context: https://bugs.webkit.org/attachment.cgi?id=208849&action=review

> Source/WebCore/html/HTMLMediaElement.cpp:283
> -    , m_cachedTimeWallClockUpdateTime(0)
> -    , m_minimumWallClockTimeToCacheMediaTime(0)
> +    , m_cachedTimeClockUpdateTime(0)
> +    , m_minimumClockTimeToCacheMediaTime(0)

These names are now confusing with the removal of "Wall".  E.g., what is a "TimeClock"?  (Arguably, they were confusing before, but they are definitely much more confusing now.)

I suggest "m_clockTimeAtLastCachedTimeUpdate" and "m_minimumClockTimeToUpdateCachedTime"

> Source/WebCore/html/HTMLMediaElement.cpp:2326
> -    if (maximumDurationToCacheMediaTime && now > m_minimumWallClockTimeToCacheMediaTime && m_cachedTime != MediaPlayer::invalidTime()) {
> -        double wallClockDelta = now - m_cachedTimeWallClockUpdateTime;
> +    if (maximumDurationToCacheMediaTime && now > m_minimumClockTimeToCacheMediaTime && m_cachedTime != MediaPlayer::invalidTime()) {
> +        double wallClockDelta = now - m_cachedTimeClockUpdateTime;

You removed "wall" from everywhere else, why not here?

Apart from the above, the changes to HTMLMediaElement and MediaController LGTM.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list