[Webkit-unassigned] [Bug 119671] FEComponentTransfer could be faster
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Aug 12 22:57:35 PDT 2013
https://bugs.webkit.org/show_bug.cgi?id=119671
--- Comment #8 from Christophe Dumez <dchris at gmail.com> 2013-08-12 22:57:10 PST ---
(From update of attachment 208582)
View in context: https://bugs.webkit.org/attachment.cgi?id=208582&action=review
The change looks good overall.
> Source/WebCore/ChangeLog:8
> + Use direct writing to target data instead of calling SET function.
SET -> Uint8ClampedArray::set()
> Source/WebCore/platform/graphics/filters/FEComponentTransfer.cpp:-171
> - unsigned char c = pixelArray->item(pixelOffset + channel);
could we maybe keep "unsigned char c = data[pixelOffset + channel];" just to improve readability a bit. It shouldn't affect performance but let me know if I'm wrong.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list