[Webkit-unassigned] [Bug 99618] [MathML] Implement the mmultiscripts tag

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 22 12:08:38 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=99618





--- Comment #24 from chris fleizach <cfleizach at apple.com>  2013-08-22 12:08:04 PST ---
(From update of attachment 208636)
View in context: https://bugs.webkit.org/attachment.cgi?id=208636&action=review

> LayoutTests/mathml/invalid-scripts-crash.html:5
> +    if (window.testRunner)

is dumpAsText necessary since this is a reftest?

> LayoutTests/mathml/presentation/multiscripts-positions.html:9
> +    <!-- This page contains several <mmultiscripts> elements. We place black squares at the position where we expect some red scripts to be, so that these scripts are hidden by the black squares. -->

can you explain why you want to add black squares in this description and how you'll use the expected test to test this.

> LayoutTests/mathml/scripts-addChild.html:17
> +      var t = document.createTextNode(n.toString());

indentation needed

> LayoutTests/mathml/scripts-removeChild.html:8
> +    <meta charset="utf-8"/>

seems unnecessary

> LayoutTests/mathml/scripts-removeChild.html:15
> +      function removeMPrescript(n)

this should be renamed to testRemovePrescript()

otherwise its confusing that Test 1-4 are captured using this function

> LayoutTests/mathml/scripts-removeChild.html:18
> +        var mmultiscripts = document.getElementById("test"+n).getElementsByTagNameNS(mathmlNS, "mmultiscripts"); 

space around "test" + n needed

> LayoutTests/mathml/scripts-removeChild.html:64
> +      removeMPrescript(1);

indendation

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list