[Webkit-unassigned] [Bug 119905] [iOS] Upstream Source/WTF

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 16 14:45:39 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=119905


Benjamin Poulain <benjamin at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #208944|review?                     |review+
               Flag|                            |




--- Comment #3 from Benjamin Poulain <benjamin at webkit.org>  2013-08-16 14:45:12 PST ---
(From update of attachment 208944)
View in context: https://bugs.webkit.org/attachment.cgi?id=208944&action=review

> Source/WTF/wtf/Assertions.h:98
> +/* For project uses WTF but has no config.h, we need to explicitly set the export defines here. */

Wrong comment style.

> Source/WTF/wtf/Platform.h:1009
> +#if (PLATFORM(IOS) && __IPHONE_OS_VERSION_MIN_REQUIRED >= 70000) || ((PLATFORM(MAC) || (OS(WINDOWS) && USE(CG))) && !PLATFORM(IOS) && __MAC_OS_X_VERSION_MIN_REQUIRED >= 1090)

Do we really need && __IPHONE_OS_VERSION_MIN_REQUIRED >= 70000?
It's not like we support anything before that.

You should get rid of the !PLATFORM(IOS) later in the list, it makes the #ifdef hard to follow.

> Source/WTF/wtf/text/StringStatics.cpp:86
> +        // On iOS WebKit, isMainThread() tests for the Web Thread, so use pthread_main_np() to ensure this is the real main thread.
> +        ASSERT(pthread_main_np());

Isn't isUIThread() solving this problem?
You could just replace ASSERT(isMainThread()); by ASSERT(isUIThread());

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list