[Webkit-unassigned] [Bug 115412] [BlackBerry] Crash due to an assert in FrameView::doDeferredRepaints

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 30 06:55:16 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115412





--- Comment #2 from Arvid Nilsson <anilsson at rim.com>  2013-04-30 06:53:38 PST ---
(From update of attachment 200102)
View in context: https://bugs.webkit.org/attachment.cgi?id=200102&action=review

LGTM with some comments

> Source/WebKit/blackberry/Api/BackingStore.cpp:393
> +        m_webPage->d->updateLayoutAndStyleIfNeededRecursive();

You could consider calling the BackingStorePrivate::requestLayoutIfNeeded() method, which encapsulates this exact call.

> Source/WebKit/blackberry/Api/BackingStore.cpp:1108
>  void BackingStorePrivate::requestLayoutIfNeeded() const

You could consider renaming this method "updateLayoutAndStyleIfNeededRecursive" to fit with the new naming scheme, but I would say the return on investment is low since we're planning to remove the BackingStore class eventually.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list