[Webkit-unassigned] [Bug 115138] [ARM] Expand the use of integer division

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 29 17:59:55 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115138


Benjamin Poulain <benjamin at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #199891|review?, commit-queue?      |review+, commit-queue-
               Flag|                            |




--- Comment #11 from Benjamin Poulain <benjamin at webkit.org>  2013-04-29 17:58:15 PST ---
(From update of attachment 199891)
View in context: https://bugs.webkit.org/attachment.cgi?id=199891&action=review

Looks reasonable.

Some comments bellow. I would prefer if Filip could double check before you land.

> Source/JavaScriptCore/ChangeLog:38
> +        (JSC::DFG::SpeculativeJIT::compileSoftModuloForX86): Added.
> +        (JSC::DFG::SpeculativeJIT::compileSoftModuloForARM): Added.
> +        (JSC::DFG::SpeculativeJIT::compileSoftModulo): Split off the X86 and ARM codegen.

Why not just name them all compileSoftModulo?
That would make the call site simpler.

> Source/JavaScriptCore/dfg/DFGOperations.cpp:1607
> +    div_t quotientAndRemainder = div(a, b);
> +    return quotientAndRemainder.rem;

a % b?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list