[Webkit-unassigned] [Bug 115022] [SH4] Misc bugfix and cleaning in sh4 base JIT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 24 14:21:47 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115022





--- Comment #7 from Mark Lam <mark.lam at apple.com>  2013-04-24 14:20:07 PST ---
(In reply to comment #6)
> > > Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:1920
> > > +                result = (cond == NonZero) ? false : true;
> > 
> > I’d suggest simplifying this to "result = (cond != NonZero);”.
> I thought of that, but I think it's easier to read and understand with the current version: if (cond == NonZero) we get a branchFalse, and a branchTrue otherwise. Of course I'm not opposed to change that if you think this is better.

I re-checked the coding style guide and didn't see anything about this.  So, I'm ok with leaving it as is.  As for the correctness of the SH4 implementation, I'll have to trust someone else's judgement on that.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list