[Webkit-unassigned] [Bug 115022] [SH4] Misc bugfix and cleaning in sh4 base JIT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 23 10:08:30 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115022





--- Comment #6 from Julien Brianceau <jbrianceau at nds.com>  2013-04-23 10:06:49 PST ---
(In reply to comment #5)
> (From update of attachment 199219 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=199219&action=review
> 
> Overall, it looks good to me, but I don’t know how SH4 works.  Have you run any tests after these changes?  For example, "Tools/Scripts/run-javascriptcode-tests" and “Tools/Scripts/run-webkit-tests fast/js/ fast/regex/ ietestcenter/Javascript/ sputnik/“.
Current state of SH4 port is not very good: I have to disable the regexp JIT (through JSC_useRegExpJIT env variable) to get something stable.

I use to run Tools/Scripts/run-javascriptcode-tests and QtTestBrowser with SunSpider 0.9.1 (http://www.webkit.org/perf/sunspider-0.9.1/sunspider-0.9.1/driver.html) on my STi7105 board to check that my patch doesn't introduce regressions.


> > Source/JavaScriptCore/assembler/MacroAssemblerSH4.h:1920
> > +                result = (cond == NonZero) ? false : true;
> 
> I’d suggest simplifying this to "result = (cond != NonZero);”.
I thought of that, but I think it's easier to read and understand with the current version: if (cond == NonZero) we get a branchFalse, and a branchTrue otherwise. Of course I'm not opposed to change that if you think this is better.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list