[Webkit-unassigned] [Bug 114596] Do not generate parameter names in WebKitIDL C++ bindings

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Apr 15 12:36:19 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=114596





--- Comment #3 from Brent Fulgham <bfulgham at webkit.org>  2013-04-15 12:34:35 PST ---
(From update of attachment 198013)
View in context: https://bugs.webkit.org/attachment.cgi?id=198013&action=review

I like the intent behind this change, but I'm wondering if we might need something more sophisticated.  When we have multiple arguments of the same type, it seems like we SHOULD have an argument name to document what the different parameters are meant to do.

Although the current labels are not all that helpful, some of them could be changed to be more descriptive.

If the IDL does not provide an argument name, will the generator produce the desired output?  Maybe fixing/adjusting the IDL would be a good thing to do instead/in addition?

> Source/WebCore/bindings/scripts/test/CPP/WebDOMTestSerializedScriptValueInterface.h:-56
> -    void multiTransferList(const WebDOMString& first, const WebDOMArray& tx, const WebDOMString& second, const WebDOMArray& txx);

Is it really improper to have some context for these arguments?  How do we know what the first and second WebDOMStrings are supposed to represent?

Maybe it's not always improper to have a label (although these labels are not very helpful!)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list