[Webkit-unassigned] [Bug 115022] [SH4] Misc bugfix and cleaning in sh4 base JIT

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 24 14:51:15 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=115022





--- Comment #10 from Julien Brianceau <jbrianceau at nds.com>  2013-04-24 14:49:33 PST ---
Thank you for your review.

(In reply to comment #9)
> I disagree, result = cond != NonZero; is much clearer (there aren't other places where we use ?: on a boolean operation to distinguish true from false

I see. According ASSERT() and previous branches, we know that (cond == Zero) or (cond == NonZero) at this point, so may I put this instead:

    result = (cond == Zero);

It would be clear for me if (cond == Zero) branchTrue() else branchFalse() and it would fit your style guidelines. Please let me know if you're ok with that, then I'll submit a new patch.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list