[Webkit-unassigned] [Bug 112327] Reorganize animation starting

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Apr 17 10:40:50 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=112327





--- Comment #14 from Antti Koivisto <koivisto at iki.fi>  2013-04-17 10:39:06 PST ---
(From update of attachment 198478)
View in context: https://bugs.webkit.org/attachment.cgi?id=198478&action=review

The basic idea of not animating on speculative tiles is good. This just needs a good universal and well-performing mechanism for restarting them when they come to view.

I wonder if it would be better at some point to make GIF animations more like other animations (driven by self-repeating timer) rather than doing the restart-timer-on-paint trick? The main benefit of that approach is the automatic stopping and restarting but if we need viewport checks and explicit restarting anyway I'm not sure if it is really helpful.

> Source/WebCore/page/FrameView.h:383
> +    bool shouldRenderAnimation(RenderObject*);
> +    void animateLater(RenderObject*);
> +    void removeSavedAnimation(RenderObject*);

FrameView is bloated. It would be better to factor this functionality to a class (ImageAnimationController?)

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list