[Webkit-unassigned] [Bug 114663] [css3-text] Rendering -webkit-hanging value for text-indent from css3-text

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 16 22:29:34 PDT 2013


https://bugs.webkit.org/show_bug.cgi?id=114663





--- Comment #3 from Jaehun Lim <ljaehun.lim at samsung.com>  2013-04-16 22:27:51 PST ---
(From update of attachment 198235)
View in context: https://bugs.webkit.org/attachment.cgi?id=198235&action=review

Thanks for your reviewing.

>> Source/WebCore/ChangeLog:9
>> +        "hanging" means "Inverts which lines are affected."
> 
> Maybe include a link to the spec?

I'll add. http://dev.w3.org/csswg/css-text/#text-indent.

>> Source/WebCore/rendering/RenderBlockLineLayout.cpp:1000
>> +        shouldIndentText == IndentText ? shouldIndentText = DoNotIndentText : shouldIndentText = IndentText;
> 
> I find this line very difficult to read. I think it is more common in WebKit to write this with the assignment operator always on the left like so:
> 
> shouldIndentText = shouldIndentText == IndentText ? DoNotIndentText : IndentText;

I'll fix.

>> LayoutTests/ChangeLog:11
>> +        * fast/css3-text/css3-text-indent/text-indent-each-line-expected.html: Removed.
> 
> Why is this file being removed? Seem like maybe removing it was a mistake? If it was not a mistake, you should explain it in the Changelog.

I just renamed and updated text-indent-each-line-expected.html to text-indent-each-line-hanging-expected.html.
But webkit-patch script recognized it as "Remove and Added". I'll fix it "Renamed" manually.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list