[Webkit-unassigned] [Bug 96610] [EFL][WK2] Regression (r128163)
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Sep 17 03:30:38 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=96610
--- Comment #4 from heejin.r.chung at samsung.com 2012-09-17 03:31:07 PST ---
(In reply to comment #3)
> (From update of attachment 163800 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=163800&action=review
> > Source/WebKit2/UIProcess/API/efl/ewk_view.cpp:501
> > + EINA_SAFETY_ON_FALSE_RETURN_VAL(!priv->evasGl, false);
> Is below code is more readable instead of above one?
> EINA_SAFETY_ON_TRUE_RETURN_VAL(priv->evasGl, false);
Using EINA_SAFETY_ON_TRUE_RETURN_VAL(priv->evasGl, false); doesn't compile.
If we want to use EINA_SAFETY_ON_TRUE_RETURN_VAL(), we have to put !! in front of priv->evasGl.
Which one should I use?
EINA_SAFETY_ON_FALSE_RETURN_VAL(!priv->evasGl, false); or
EINA_SAFETY_ON_TRUE_RETURN_VAL(!!priv->evasGl, false);
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list