[Webkit-unassigned] [Bug 94925] [EFL][UT]Refactoring an implementation of testing framework for wk1.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 12 08:39:48 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94925





--- Comment #12 from Krzysztof Czech <k.czech at samsung.com>  2012-09-12 08:40:13 PST ---
(In reply to comment #10)
> (From update of attachment 163576 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=163576&action=review
> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestBase.cpp:69
> > +void EWKTestBase::onLoadFinished(void* data, Evas_Object* webView, void* eventInfo)
> >  {
> > -    return createTest(Config::defaultTestPage, event_callback, event_name, event_data);
> > +    UNUSED_PARAM(data);
> > +    UNUSED_PARAM(webView);
> > +    UNUSED_PARAM(eventInfo);
> 
> Could you check whether compiler complains with void EWKTestBase::onLoadFinished(void*, Evas_Object*, void*) ?

I checked and this build configuration (it might be changed someday to be more restrictive) doesn't complain.
Ok, I will correct this.

> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:44
> > +bool EWKTestView::init()
> 
> Isn't it better to pass viewtype, width, height instead of keeping them ?
> 
> and initialize looks better.

You mean passing from command line ?
I proposed EWKTestConfig.h to keep constants in terms of readability.

> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:76
> > +    evas_object_focus_set(m_webView, EINA_TRUE);
> 
> true ?

You mean true as boolean value ?. Well I wanted to be coherent with function's declaration. It declares Eina_Bool.

> 
> > Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.h:42
> > +    void viewTypeSet(EwkViewType testViewType) { m_viewType = testViewType; }
> 
> I think that it looks meaningless.

Let me explain, why I proposed this method.
This method gives possibility to test Tiled and Single backing store even in one test's translation unit.
By default Tiled backingstore is created. viewTypeSet gives possibility to change this to SingleView in other test case before runTest (btw. runTest is a bit ambiguous, rather should be loadTest) is calling.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list