[Webkit-unassigned] [Bug 96308] percentage widths rendered wrong in vertical writing mode with orthogonal parent

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 11 09:52:32 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=96308





--- Comment #2 from John Mellor <johnme at chromium.org>  2012-09-11 09:52:55 PST ---
(In reply to comment #1)
> We could rename these logicalHeightFor(RenderBox* other)?

Alternatively, doing it the other way round, it might be useful to expose getters that take a writing mode, instead of using their own, something like:
LayoutUnit logicalHeightIn(EWritingMode)
{
    return EWritingMode == HORIZONTAL_TB ? height() : width();
}

Though I guess we can't produce a ternary value from RenderObject's m_bitfields.horizontalWritingMode(), and there's already a WritingMode enum in platform/text/WritingMode.h, so this probably isn't the best choice of enum...

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list