[Webkit-unassigned] [Bug 96114] [chromium] Make prioritized texture manager not touch backings array on the main thread

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 10 21:43:08 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=96114


James Robinson <jamesr at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #163272|review?                     |review+
               Flag|                            |




--- Comment #28 from James Robinson <jamesr at chromium.org>  2012-09-10 21:43:30 PST ---
(From update of attachment 163272)
View in context: https://bugs.webkit.org/attachment.cgi?id=163272&action=review

This looks really nice to me.

I think one tradeoff to keep in mind in general with these classes is that they seem to always end up being fairly deeply aware of our commit flow, our threaded use of the class, or both.  I think being aware of the commit flow - i.e. what things happen in what order from what threads - tends to be the least intrusive of all of these.

> Source/WebCore/platform/graphics/chromium/cc/CCPrioritizedTextureManager.cpp:397
> +        if ((*it)->hadOwnerAtLastPriorityUpdate())

I think putting (*it) in an appropriately-named-and-typed temporary would be a big readability win for this section

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list