[Webkit-unassigned] [Bug 78493] [CSSRegions][CSSOM] Implement Element.getRegionFlowRanges

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 10 10:05:57 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=78493


Dave Hyatt <hyatt at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #162511|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #8 from Dave Hyatt <hyatt at apple.com>  2012-09-10 10:06:16 PST ---
(From update of attachment 162511)
View in context: https://bugs.webkit.org/attachment.cgi?id=162511&action=review

Looks good. Just minor nits. I would possibly think about that writing mode section, since it feels like that could be simplified to me, but if you fix the other issues I pointed out that's good enough for a +.

> Source/WebCore/rendering/RenderBlock.cpp:7220
> +        if (containerBlock->style()->writingMode() != currentBlock->style()->writingMode()) {

You can use the method isWritingModeRoot() here. That's cleaner than having to compare the writing mode styles.

> Source/WebCore/rendering/RenderBlock.cpp:7231
> +            if (containerBlock->style()->isFlippedBlocksWritingMode()) {
> +                if (containerBlock->isHorizontalWritingMode())
> +                    blockRect.setY(currentBlock->height() - blockRect.maxY());
> +                else
> +                    blockRect.setX(currentBlock->width() - blockRect.maxX());
> +            }
> +            currentBlock->flipForWritingMode(blockRect);
> +        }
> +        blockRect.moveBy(currentBlockLocation);

I think this is correct, but it feels kind of convoluted to me. I think it could be simplified, but I won't hold up review for it.

> Source/WebCore/rendering/RenderBlock.cpp:7234
> +    return currentBlock->isHorizontalWritingMode() ? blockRect.y().toInt() : blockRect.x().toInt();

You should not be returning toInt() here, should you? Your function is returning a LayoutUnit, which means you don't need to be converting to int.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list