[Webkit-unassigned] [Bug 95672] [EFL][WK2] Add javascript popup api.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 3 18:52:12 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=95672


Gyuyoung Kim <gyuyoung.kim at samsung.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #161938|review?                     |review-
               Flag|                            |




--- Comment #2 from Gyuyoung Kim <gyuyoung.kim at samsung.com>  2012-09-03 18:52:23 PST ---
(From update of attachment 161938)
View in context: https://bugs.webkit.org/attachment.cgi?id=161938&action=review

> Source/WebKit2/ChangeLog:8
> +        Added ewk api for javascript alert(), confirm() and prompt().

s/api/API/g

> Source/WebKit2/UIProcess/API/efl/ewk_view.cpp:1594
> +void ewk_view_javascript_prompt_finished(Evas_Object*ewkView, const char* result)

Missing a space in Evas_Object*ewkView.

> Source/WebKit2/UIProcess/API/efl/ewk_view.cpp:1599
> +    priv->javascriptPromptResult = adoptPtr(new CString(result ? result : ""));

Isn't this better ?

result ? adoptPtr(new CString(result)) : 0;

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:243
> +            char *message; /**< message for alert()*/

Missing a space in "alert()*/"

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:246
> +            char *message; /**< message for confirm()*/

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:249
> +            char *message; /**< message for prompt()*/

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:250
> +            char *default_value; /**< default value for prompt() input box*/

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view_private.h:104
> +PassOwnPtr<CString> ewk_view_run_javascript_prompt(Evas_Object* ewkView, char* message, char* default_value);

s/defalut_value/defaultValue/g

> Source/WebKit2/UIProcess/API/efl/ewk_view_ui_client.cpp:77
> +    return WKStringCreateWithUTF8CString(result ? result->data() : "");

I think this one is better. 

result ? adoptWK(WKStringCreateWithUTF8CString(result->data())) : 0;

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list