[Webkit-unassigned] [Bug 97860] New: Make functions in Localizer class "const"

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 27 21:57:26 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=97860

           Summary: Make functions in Localizer class "const"
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: Platform
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: yosin at chromium.org


Following functions in class Localizer[1] should have "const" specifier to use constant reference to Localizer object for code readability and allow optimization by compiler.

 - convertToLocalizedNumber()
 - convertFromLocalizedNumber()
 - localizedDecimalSeparator()
 - timeFormat()
 - shortTimeFormat()
 - timeAMPMLabels()

Once we can use constant reference Localizer object, we should change use sites to use constant reference, please file another bug:
 - Localizer& Documenet::getLocalizer()
 - BaseMultipleFieldsDateAndTimeInputType::updateInnerTextValue()
    Localizer& localizer = element()->document()->getLocalizer(element()->computeInheritedLanguage());
 - DateTimeEditBuilder member variable
    Localizer& m_localize
 - DateTimeEditElement::LayoutParameters
    LayoutParameters(Localizer& localizer, const StepRange& stepRange)
    Localizer& localizer
 - Maybe more

= References =
[1] http://trac.webkit.org/browser/trunk/Source/WebCore/platform/text/Localizer.h

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list