[Webkit-unassigned] [Bug 94925] [EFL][UT]Refactoring an implementation of testing framework for wk1.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 12 09:27:52 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=94925





--- Comment #14 from Ryuan Choi <ryuan.choi at samsung.com>  2012-09-12 09:28:17 PST ---
(From update of attachment 163576)
View in context: https://bugs.webkit.org/attachment.cgi?id=163576&action=review

>>> Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:44
>>> +bool EWKTestView::init()
>> 
>> Isn't it better to pass viewtype, width, height instead of keeping them ?
>> 
>> and initialize looks better.
> 
> You mean passing from command line ?
> I proposed EWKTestConfig.h to keep constants in terms of readability.

I just mean passing them as argument of init() instead of argument of constructor.

>>> Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.cpp:76
>>> +    evas_object_focus_set(m_webView, EINA_TRUE);
>> 
>> true ?
> 
> You mean true as boolean value ?. Well I wanted to be coherent with function's declaration. It declares Eina_Bool.

As following http://trac.webkit.org/wiki/EFLWebKitCodingStyle, we use true instead of EINA_TRUE in webkit internal.

>>> Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.h:42
>>> +    void viewTypeSet(EwkViewType testViewType) { m_viewType = testViewType; }
>> 
>> I think that it looks meaningless.
> 
> Let me explain, why I proposed this method.
> This method gives possibility to test Tiled and Single backing store even in one test's translation unit.
> By default Tiled backingstore is created. viewTypeSet gives possibility to change this to SingleView in other test case before runTest (btw. runTest is a bit ambiguous, rather should be loadTest) is calling.

After called viewTypeSet, we should call init to really change the type of view.(and it is not used in other areas.
So, I think that we can just pass  type to init as a parameter.

> Source/WebKit/efl/tests/UnitTestUtils/EWKTestView.h:-66
> -    OwnPtr<Evas_Object> m_webView;

I will check which warning is generated.

But I believe that we can ensure destructor of members will be called in order.
We can just add comment like http://trac.webkit.org/browser/trunk/Source/WebCore/platform/efl/RenderThemeEfl.h#L251

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list