[Webkit-unassigned] [Bug 95625] [CSS Exclusions] add support for a subset of the basic shapes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 6 11:37:59 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=95625





--- Comment #15 from Hans Muller <giles_joplin at yahoo.com>  2012-09-06 11:38:13 PST ---
(In reply to comment #5)
> (From update of attachment 161830 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=161830&action=review

If, per comment #10, it's OK to make the changes vis logical vs physical geometry in a separate bug fix, I'd like to address the following then:

> Do you mean logical top rather than Y?
> 
> > Source/WebCore/platform/graphics/XSRectangle.h:39
> > +class XSRectangle : public XShape {
> 
> I think a comment above this class declaration describing what it represents might be helpful here.

[I've proposed such a comment in #10.  Since it depends on resolving logical vs physical geometry, I'd like to include with that TBD patch]

> > Source/WebCore/platform/graphics/XShape.h:43
> > +    static PassOwnPtr<XShape> createXShape(const BasicShape*, float borderBoxWidth, float borderBoxHeight);
> 
> borderBoxWidth and borderBoxHeight are physical terminology. Is this physical or logical? I'm confused about this.
> 
> > Source/WebCore/rendering/WrapShapeInfo.cpp:110
> > +    m_xshape = XShape::createXShape(shape, logicalWidth, logicalHeight);
> 
> Here you're passing in logical values to a function whose (see my comment above)  arguments had physical names. Which is correct?
> 
> > Source/WebCore/rendering/WrapShapeInfo.h:70
> > +    LayoutUnit shapeTop() const 
> 
> Is this logical or physical? If it's supposed to be a value that is compared with a line top or bottom, then this should be renamed to shapeLogicalTop().
> 
> > Source/WebCore/rendering/WrapShapeInfo.h:103
> > +    FloatRect shapeBounds = m_xshape->shapeBoundingBox();
> 
> This appears to be logical. Is that the intent?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list