[Webkit-unassigned] [Bug 68303] Memory leak using web SQL DB
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Oct 24 23:53:17 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=68303
--- Comment #12 from Adam Barth <abarth at webkit.org> 2012-10-24 23:54:23 PST ---
(From update of attachment 169122)
View in context: https://bugs.webkit.org/attachment.cgi?id=169122&action=review
> Source/WebCore/Modules/webdatabase/Database.cpp:170
> + ScriptExecutionContext* copy = scriptExecutionContext.get();
> + copy->postTask(DerefContextTask::create(scriptExecutionContext));
I probably would have picked another name than "copy" here. It's not really a copy of the scriptExecutionContext (which is non-copiable).
> Source/WebCore/Modules/webdatabase/DatabaseThread.cpp:168
> + virtual const char* debugTaskName() const { return "CloseDatabaseCloserTask"; }
I presume this is an OVERRIDE
> Source/WebCore/Modules/webdatabase/DatabaseThread.cpp:174
> + : DatabaseTask(0, 0)
> + , m_closer(closer)
Bad indent.
> Source/WebCore/Modules/webdatabase/DatabaseThread.cpp:185
> + m_queue.prepend(CloseDatabaseCloserTask::create(closer));
prepend, interesting.
> Source/WebCore/Modules/webdatabase/DatabaseThread.h:88
> - typedef HashSet<RefPtr<Database> > DatabaseSet;
> + typedef HashSet<RefPtr<DatabaseCloser> > DatabaseSet;
I see, this is the point of the whole thing.
> Source/WebKit/chromium/src/WebDatabase.cpp:65
> + if (!m_stringIdentifier.isNull())
> + return m_stringIdentifier;
This seems like a hack. We should just change the API properly.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list