[Webkit-unassigned] [Bug 100321] Refactor LLInt64 to distinguish the pointer operations from the 64-bit integer operations
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Oct 24 20:48:50 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=100321
Filip Pizlo <fpizlo at apple.com> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #170542|review? |review-
Flag| |
--- Comment #2 from Filip Pizlo <fpizlo at apple.com> 2012-10-24 20:49:57 PST ---
(From update of attachment 170542)
View in context: https://bugs.webkit.org/attachment.cgi?id=170542&action=review
I think you should fix the X86_INSTRUCTIONS part but otherwise I like where this is going.
> Source/JavaScriptCore/offlineasm/instructions.rb:216
> +X86_64_INSTRUCTIONS =
The X86_INSTRUCTIONS, and ARMv7_INSTRUCTIONS are used for instructions that are truly artifacts of that architecture.
The cloop might be built in JSVALUE64 mode on non-X86 64-bit architectures. Like, I dunno, PowerPC maybe. I don't know if anyone does that, but it would be really weird to name these X86_64_INSTRUCTIONS and then have a PowerPC 64-bit port that uses them.
I suggest putting these instructions into the main instruction list.
> Source/JavaScriptCore/offlineasm/x86.rb:55
> - "*#{x86Operand(kind)}"
> + "*#{x86Operand(:quad)}"
Is that right? Shouldn't this be :ptr?
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list