[Webkit-unassigned] [Bug 93922] [Shadow DOM] Insertion points need resetStyleInheritance

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 9 10:03:46 PDT 2012


Dimitri Glazkov (Google) <dglazkov at chromium.org> changed:

           What    |Removed                     |Added
                 CC|                            |dglazkov at chromium.org

--- Comment #7 from Dimitri Glazkov (Google) <dglazkov at chromium.org>  2012-10-09 10:04:21 PST ---
(In reply to comment #6)
> (From update of attachment 167694 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=167694&action=review
> > Source/WebCore/css/StyleResolver.cpp:1066
> > +inline bool isResetStyleInheritance(NodeRenderingContext& context)
> It makes no sense to say that a context “is reset style inheritance”. Instead we should ask if a context “should reset style inheritance” or “resets style inheritance”.
> > Source/WebCore/html/shadow/InsertionPoint.h:81
> > +    bool m_resetStyleInheritance : 1;
> It’s unfortunate that the shadow specification gives a property a verb phrase name. The function resetStyleInheritance sounds like something that would perform a reset operation, not a getter that returns a boolean.

Hey, you have the spec editor's ears right here :)

It's a flag that, if set, will reset style inheritance. What would be a better name?

> We don’t have to repeat that mistake in our data member. I would suggest the name “m_shouldResetStyleInheritance” or at least “m_resetsStyleInheritance”, and also suggest discussing changing the name in the spec.

Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the webkit-unassigned mailing list