[Webkit-unassigned] [Bug 93170] Inline continuations create :after generated content on style recalcs
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Oct 2 09:03:38 PDT 2012
https://bugs.webkit.org/show_bug.cgi?id=93170
Abhishek Arya <inferno at chromium.org> changed:
What |Removed |Added
----------------------------------------------------------------------------
Attachment #166633|review? |review+, commit-queue-
Flag| |
--- Comment #17 from Abhishek Arya <inferno at chromium.org> 2012-10-02 09:04:01 PST ---
(From update of attachment 166633)
View in context: https://bugs.webkit.org/attachment.cgi?id=166633&action=review
> Source/WebCore/rendering/RenderInline.cpp:177
> + RenderObjectChildList::m_enableUpdateAfterContent = !nextTarget;
You don't need lines 176 and 177. As i said in last comment, you are explicitly updating :before, :after content later in function, so it will place it correctly at end.
nextTarget = currCont->inlineElementContinuation();
RenderObjectChildList::m_enableUpdateAfterContent = !nextTarget;
> Source/WebCore/rendering/RenderObjectChildList.cpp:379
> + if (type == AFTER && !m_enableUpdateAfterContent)
You don't need to just check AFTER, make it generic and rename m_enableUpdateAfterContent to s_enableUpdateBeforeAfterContent. For :before content, you will bail early here instead of wasting time and going till " if (newContentWanted && type == BEFORE && owner->isElementContinuation())"
> Source/WebCore/rendering/RenderObjectChildList.h:64
> + static bool m_enableUpdateAfterContent;
rename to s_enableUpdateBeforeAfterContent. we s_ for statics.
--
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
More information about the webkit-unassigned
mailing list