[Webkit-unassigned] [Bug 93922] [Shadow DOM] Insertion points need resetStyleInheritance

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 9 21:51:30 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=93922





--- Comment #11 from Takashi Sakamoto <tasak at google.com>  2012-10-09 21:52:07 PST ---
(From update of attachment 167694)
View in context: https://bugs.webkit.org/attachment.cgi?id=167694&action=review

Thank you for reviewing.

>>> Source/WebCore/css/StyleResolver.cpp:1066
>>> +inline bool isResetStyleInheritance(NodeRenderingContext& context)
>> 
>> It makes no sense to say that a context “is reset style inheritance”. Instead we should ask if a context “should reset style inheritance” or “resets style inheritance”.
> 
> Hey, you have the spec editor's ears right here :)
> 
> It's a flag that, if set, will reset style inheritance. What would be a better name?

As resetStyleInheritance in HTMLShadowElement.idl and HTMLContentElement.idl  is defined in Shadow DOM spec, we cannot change the code. Firstly we have to change the spec.
However talking about this inline function and m_resetStyleInhertiance in class InsertionPoint, we can change. So I renamed.

>> Source/WebCore/html/shadow/HTMLShadowElement.idl:37
>> +        attribute boolean resetStyleInheritance;
> 
> What about adding the attribute to HTML?

Would you mean moving resetStyleInheritance from HTMLShadow/ContentElement.idl to HTMLElement.idl?
If so, I talked with morrita@ and haraken@ about this and heard that IDL files allow such duplication and it is bad to add resetStyleInheritance to HTMLElement because users can see HTMLElement has resetStyleInheritance.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list