[Webkit-unassigned] [Bug 98344] [EFL] Add the file system path set/get APIs.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 4 06:44:20 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=98344





--- Comment #8 from Christophe Dumez <christophe.dumez at intel.com>  2012-10-04 06:44:45 PST ---
(In reply to comment #3)
> (In reply to comment #2)
> > (From update of attachment 167043 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=167043&action=review
> > 
> > > Source/WebKit/efl/ewk/ewk_settings.cpp:153
> > > +    WebCore::LocalFileSystem::initializeLocalFileSystem(WTF::String::fromUTF8(path));
> > 
> > WTF:: is probably not needed.
> > 
> > WebCore::LocalFileSystem::initializeLocalFileSystem() can only be called *ONCE* due to the ASSERT(!s_instance); in debug mode.
> > This makes this API useless since ewk_settings_file_system_path_set() is already called once from ewk_main. Therefore, it is no longer possible for the app to change it later.
> > 
> 
> What do you mean "app" in your comment above?
> 
> If you mean web apps, web apps are not supposed to change the path.
> The url of web app will be used as the name of directory.
> (e.g. <base_path>/<path_made_by_the_url>)
> 
> If you mean native apps, it could set the path using the XDG_DATA_HOME.

By app, I mean the browser for example.

What's the point of adding a public API (ewk_settings_file_system_path_set) if the browser can NOT call it? IMO, it should be private and called only once in ewk_main.

Right now, you add a public function that will hit an assertion if the browser calls it :( I don't see the point.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list