[Webkit-unassigned] [Bug 102240] [V8] Rename dispatchWrap

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 27 02:03:14 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=102240





--- Comment #8 from Dan Carney <dcarney at google.com>  2012-11-27 02:05:25 PST ---

> - If we want to write custom toV8(), we need to specify [(V8)CustomToJSObject] and [V8NoWrapperCache].

no, you just need V8NoWrapperCache, which means we don't care about caching, which in turn means we can't generate a toV8, so you must provide one.

> - Then what should we specify if we want to write both custom toV8() and custom wrap() ?

it's not a case that makes sense. either we want the wrapper cache, in which case toV8 is automatically generated, or we don't, in which case we must supply toV8 ourselves, and all wrap methods will be not generated.

> [2] Do we really need to expose both custom toV8() and custom wrap() to make the number of cache checks once ?

yes, because a custom toV8 function has no wrapper checks.

> [3] Just to clarify, would you elaborate on why the following structure won't work? (I'd like to understand what is making the situation complicated.)
> 
>   call path: toV8Fast() => toV8() => createWrapper()
> 
>   - toV8Fast() does the cache check.
>   - toV8() can be custom to let developers write any delegation logic.
>   - createWrapper() creates a new V8 object.

that's essentially what we have, except if you rename toV8Fast to toV8 and toV8 to wrap. 


the problem with what you seem to want is that toV8Fast is only suitable for some places, so toV8 also needs to exist and do a wrapper check, which means 2 wrapper checks for those places

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list