[Webkit-unassigned] [Bug 93646] Refactor V8 bindings to allow content scripts to access subframes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 26 12:25:27 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=93646





--- Comment #16 from Dan Carney <dcarney at google.com>  2012-11-26 12:27:36 PST ---
(In reply to comment #15)
> (From update of attachment 175963 [details])
> This patch is great and exactly how I'd hoped we'd be able to implement this feature.
> 
> My only real comment is stylistic.  I'd add a helper function align the lines of
> 
> inline v8::Local<v8::Context> ScriptController::contextForWorld(DOMWrapperWorld* world)
> {
>     return v8::Local<v8::Context>::New(windowShell(world)->context());
> }

Okay, will add. I was inlining those since i figured the first couple branches at least got hit a lot in the perf tests.

> 
> since you use that idiom a bunch.
> 
> Once this rolls into Chromium, would you be willing to add extension API test so we can test the integration with the extension system?

sure. i've put it on my todo list.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list