[Webkit-unassigned] [Bug 93646] Refactor V8 bindings to allow content scripts to access subframes

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Nov 26 11:06:40 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=93646


Adam Barth <abarth at webkit.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #175963|review?                     |review+
               Flag|                            |




--- Comment #15 from Adam Barth <abarth at webkit.org>  2012-11-26 11:08:50 PST ---
(From update of attachment 175963)
This patch is great and exactly how I'd hoped we'd be able to implement this feature.

My only real comment is stylistic.  I'd add a helper function align the lines of

inline v8::Local<v8::Context> ScriptController::contextForWorld(DOMWrapperWorld* world)
{
    return v8::Local<v8::Context>::New(windowShell(world)->context());
}

since you use that idiom a bunch.

Once this rolls into Chromium, would you be willing to add extension API test so we can test the integration with the extension system?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list