[Webkit-unassigned] [Bug 103175] Make renderer construction less generic

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Nov 24 12:03:58 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=103175





--- Comment #10 from Elliott Sprehn <esprehn at chromium.org>  2012-11-24 12:06:04 PST ---
(From update of attachment 175855)
View in context: https://bugs.webkit.org/attachment.cgi?id=175855&action=review

> Source/WebCore/dom/NodeRenderingContext.cpp:217
>      moveToFlowThreadIfNeeded();

You should remove isElementNode() check in moveToFlowThreadIfNeeded() since we never call it on non-elements with this patch.

> Source/WebCore/dom/NodeRenderingContext.cpp:219
> +    if (!element->rendererIsNeeded(*this)) {

Can we either rename this elementRendererIsNeeded to match the new createRendererForElementIfNeeded or leave the method name alone for createRendererIfNeeded (as you have textRendererIsNeeded and createTextRenderer)? We lose the parity in the methods from this patch.

> Source/WebCore/dom/Text.cpp:306
> +{

The old version of this method was shorter and seemed easier to understand.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list