[Webkit-unassigned] [Bug 102452] Plumbing showPaintRects out of InspectorPageAgent to use a different drawing implementation if available.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 20 10:49:22 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=102452


Pavel Feldman <pfeldman at chromium.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #174747|review?                     |review-
               Flag|                            |




--- Comment #7 from Pavel Feldman <pfeldman at chromium.org>  2012-11-20 10:51:21 PST ---
(From update of attachment 174747)
View in context: https://bugs.webkit.org/attachment.cgi?id=174747&action=review

Looks good overall, couple of naming nits and it can land.

> Source/WebCore/inspector/InspectorClient.h:75
> +    virtual bool canShowPaintRects() { return false; }

So its semantics is a bit different: it tells you whether embedder should handle paint rects. I'd name it overridesShowPaintRects().

> Source/WebKit/chromium/public/WebView.h:474
> +    virtual bool canShowHUDLayer() = 0;

Should this be called isAcceleratedCompositingActive ? Just to make things more clear.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list