[Webkit-unassigned] [Bug 101748] [WK2][GTK][EFL] Share WebKit2-GTK's Accessibility implementation with other WebKit ports.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 16 04:24:42 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=101748





--- Comment #19 from Mario Sanchez Prada <mario at webkit.org>  2012-11-16 04:26:32 PST ---
(From update of attachment 174638)
View in context: https://bugs.webkit.org/attachment.cgi?id=174638&action=review

The changes look good to me. Actually the only comment I can make about them is about fixing an issue with naming I'm guilty of :/

Additionally, besides the code in this patch (which is about the AtkPlug part in the Web process only), I wonder if it could be possible to share the bits in WebKit2/UIProcess/API/gtk/WebKitWebViewBaseAccessible.[cpp|h] as well, as they implement the other side of this thing (the AtkSocket part in the UI process).

Or maybe you were already thinking of doing that in a separate bug?

> Source/WebKit2/WebProcess/WebPage/atk/WebPageAccessibilityObjectAtk.cpp:60
> +    Page* page = accessible->m_page->corePage();
> +    if (!page)
> +        return 0;
> +
> +    Frame* core = page->mainFrame();
> +    if (!core || !core->document())
> +        return 0;
> +
> +    AccessibilityObject* root = core->document()->axObjectCache()->rootObject();
> +    if (!root)
> +        return 0;
> +
> +    AtkObject* axRoot = root->wrapper();

I know I'm the one to blame for this in the first place, but perhaps this patch is a good moment to use more meaningful names here :)

  page -> corePage
  core -> coreFrame
  root -> coreRootObject
  axRoot -> rootObject (to be consistent with the rest of this file)

... or something like that.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list