[Webkit-unassigned] [Bug 101291] [EFL] Refactor GraphicsContext3DEFL

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 16 00:22:41 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=101291





--- Comment #32 from Kenneth Rohde Christiansen <kenneth at webkit.org>  2012-11-16 00:24:30 PST ---
(From update of attachment 174621)
View in context: https://bugs.webkit.org/attachment.cgi?id=174621&action=review

> Source/WebCore/platform/graphics/efl/GLContext.h:1
> +/*

Will you move these to say Source/WebCore/platform/graphics/opengl/GLContext.h ?

> Source/WebCore/platform/graphics/surfaces/glx/GLXSurface.cpp:100
> +{
> +    if (m_drawable) {
> +        if (m_restoreNeeded) {
> +            GLint oldFBO;
> +            glGetIntegerv(GL_FRAMEBUFFER_BINDING, &oldFBO);
> +            glBindFramebuffer(GL_FRAMEBUFFER, 0);
> +            glXSwapBuffers(sharedDisplay(), m_drawable);
> +            glBindFramebuffer(GL_FRAMEBUFFER, oldFBO);
> +        } else
> +            glXSwapBuffers(sharedDisplay(), m_drawable);
> +    }
> +}

This we write as 

if (!m_drawable)
    return;

...

> Source/WebCore/platform/graphics/surfaces/glx/GLXSurface.cpp:179
> +    return pBufferConfig();

pBufferConfiguration then, or just rename this to config() then. We need to be consistent

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list