[Webkit-unassigned] [Bug 102240] [V8] Rename dispatchWrap

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 27 06:40:09 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=102240





--- Comment #10 from Dan Carney <dcarney at google.com>  2012-11-27 06:42:21 PST ---

> Maybe we want to change it like this?
> 
> - [(V8)CustomToJSObject] => we can write custom toV8()
> - [V8CustomWrap] => we can write custom wrap()

CustomToJSObject can't be renamed since jsc uses it.  V8 bindings would have to stop using it almost altogether. You'd have to split every current instance of it into JSCustomToJSObject and V8CustomWrap and then if you renamed V8NoWrapperCache to V8CustomToJSObject, you could recollect the cases where V8CustomToJSObject and JSCustomToJSObject coincided into CustomToJSObject, which wouldn't be many places.

> Another confusion comes from the fact that [(V8)CustomToJSObject] is specified for all IDL files that have [V8NoWrapperCache]. The [(V8)CustomToJSObject] is useless (ignored in code generators). We can remove the [(V8)CustomToJSObject] from those IDL files.

The redundancy doesn't really matter. I think I may even have added an assertion that one implied the other.

Anyway, if you want to rename stuff, I certainly don't mind either way, and it would definitely be a small improvement in the readability of the code gen file.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list