[Webkit-unassigned] [Bug 87743] Crash in WebCore::SubresourceLoader::releaseResources when connection fails

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 20 03:05:17 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=87743


Antti Koivisto <koivisto at iki.fi> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #149309|review?, commit-queue?      |review-, commit-queue-
               Flag|                            |




--- Comment #22 from Antti Koivisto <koivisto at iki.fi>  2012-11-20 03:07:15 PST ---
(From update of attachment 149309)
View in context: https://bugs.webkit.org/attachment.cgi?id=149309&action=review

Seems like a sensible change. Naming should be improved though.

> Source/WebCore/loader/cache/CachedResource.h:205
> +    void cancelled();

Loader code has hots of bad legacy naming but we shouldn't add more. Please follow the usual naming rules. This should be something like cancelLoad().

> Source/WebCore/loader/ResourceLoader.h:160
> +        bool cancelled() const { return m_cancellationStatus >= Cancelled; }

Here is another cancelled() now with bool return. It should be along the lines of wasCanceled().

> Source/WebCore/loader/SubresourceLoader.h:78
> +    void finish();

These need more descriptive name as well. Finish what? Finish how?

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list