[Webkit-unassigned] [Bug 101367] New: check-webkit-style false report about asm() code in DFGOperations.cpp.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 6 10:08:17 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=101367

           Summary: check-webkit-style false report about asm() code in
                    DFGOperations.cpp.
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Other
        OS/Version: Linux
            Status: UNCONFIRMED
          Severity: Normal
          Priority: P2
         Component: JavaScriptCore
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: kilvadyb at homejinni.com
                CC: levin at chromium.org, fu at mips.com,
                    gergely at homejinni.com, palfia at homejinni.com


As I didn't find coding style rules to asm(…) blocks just followed the style/indention of existing asm(… ) blocks but received:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/JavaScriptCore/ChangeLog', u'Source..." exit_code: 1
Source/JavaScriptCore/dfg/DFGOperations.cpp:1569:  The parameter name """" adds no information, so it should be removed.  [readability/parameter_name] [5]

for:

asm(
".text" "\n"
".globl " SYMBOL_STRING(getHostCallReturnValue) "\n"
HIDE_SYMBOL(getHostCallReturnValue) "\n"
SYMBOL_STRING(getHostCallReturnValue) ":" "\n"
    LOAD_FUNCTION_TO_T9(getHostCallReturnValueWithExecState)
    "lw $s0, -40($s0)" "\n"
    "move $a0, $s0" "\n"
    "b " LOCAL_REFERENCE(getHostCallReturnValueWithExecState) "\n"
);

Where line 1569 is the closing );

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list