[Webkit-unassigned] [Bug 101193] [EFL][WK2] Add ewk_database_manager APIs

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Nov 6 00:53:53 PST 2012


https://bugs.webkit.org/show_bug.cgi?id=101193





--- Comment #3 from Christophe Dumez <christophe.dumez at intel.com>  2012-11-06 00:55:23 PST ---
(From update of attachment 172452)
View in context: https://bugs.webkit.org/attachment.cgi?id=172452&action=review

> Source/WebKit2/UIProcess/API/efl/ewk_context_private.h:58
> +    Ewk_Database_Manager* databaseManager() const;

Should not be const as per WebKit coding style.

> Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:44
> +void Ewk_Database_Manager::getDatabaseOrigins(void* context, WKDatabaseManagerGetDatabaseOriginsFunction callback) const

We usually pass user data *after* the callback, not before.

>> Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:67
>> +struct Ewk_Database_Origins_Async_Get_Context {
> 
> Can't we use class instead of struct ? As you know, EFL port start to use class for internal usage.

It's only a callback struct, I think it is OK to leave it as is. We still use structs for this case in the rest of the code I believe.

> Source/WebKit2/UIProcess/API/efl/ewk_database_manager.cpp:81
> +    Eina_List* originList = 0;

Should be declared when it is used below. This is nicer C++ style.

> Source/WebKit2/UIProcess/API/efl/tests/test_ewk2_database_manager.cpp:29
> +#include <EWebKit2.h>

You forgot to add ewk_database_manager.h to <EWebKit2.h>.

> Source/WebKit2/UIProcess/API/efl/tests/test_ewk2_database_manager.cpp:31
> +#include <gtest/gtest.h>

Do we really need this header?

> Source/WebKit2/UIProcess/API/efl/tests/test_ewk2_database_manager.cpp:40
> +    unsigned timeToCheck;

Bad variable name.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list