[Webkit-unassigned] [Bug 74111] Some overlay scrollbar API calls in ScrollAnimatorMac can lead to an assertion in RenderBox::mapAbsoluteToLocalPoint

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 08:38:59 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=74111


Simon Fraser (smfr) <simon.fraser at apple.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #145022|review?                     |review-
               Flag|                            |




--- Comment #7 from Simon Fraser (smfr) <simon.fraser at apple.com>  2012-05-31 08:38:59 PST ---
(From update of attachment 145022)
View in context: https://bugs.webkit.org/attachment.cgi?id=145022&action=review

> ManualTests/scrollbar-crash-on-hide-scrolled-area.html:33
> +    <a href="#" class=​"nextStepButton" onclick="document.getElementById('toHide').style.display='none'">​Next step​</a>​

There are still some non-ascii characters here. The testcase could be cleaned further.

> Source/WebCore/platform/mac/ScrollAnimatorMac.mm:1239
> +void ScrollAnimatorMac::startNotifyContentAreaScrolledTimer()
> +{
> +    m_notifyContentAreaScrolledTimer.startOneShot(0);
> +}

It would be slightly cleaner to move the isActive check in here, and rename this method to 'sendContentAreaScrolledSoon' or something. Then you don't need the notifyContentAreaScrolledTimerIsActive() method, which has a confusing name anyway.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the webkit-unassigned mailing list