[Webkit-unassigned] [Bug 86498] [EFL][DRT] LayoutTestController does not implement originsWithApplicationCache

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 31 06:33:20 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86498


Gustavo Noronha (kov) <gns at gnome.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
 Attachment #144495|review?                     |review+
               Flag|                            |




--- Comment #12 from Gustavo Noronha (kov) <gns at gnome.org>  2012-05-31 06:33:19 PST ---
(From update of attachment 144495)
View in context: https://bugs.webkit.org/attachment.cgi?id=144495&action=review

> Source/WebKit/efl/WebCoreSupport/DumpRenderTreeSupportEfl.cpp:686
> +    HashSet<RefPtr<WebCore::SecurityOrigin>, WebCore::SecurityOriginHash> origins;
> +    WebCore::cacheStorage().getOriginsWithCache(origins);
> +
> +    HashSet<RefPtr<WebCore::SecurityOrigin>, WebCore::SecurityOriginHash>::const_iterator it;
> +    HashSet<RefPtr<WebCore::SecurityOrigin>, WebCore::SecurityOriginHash>::const_iterator end = origins.end();
> +
> +    JSValueRef jsOriginsArray[origins.size()];
> +    uint i = 0;
> +    for (it = origins.begin(); it != end; ++it) {
> +        JSStringRef originJS = JSStringCreateWithUTF8CString(it->get()->databaseIdentifier().utf8().data());
> +        jsOriginsArray[i++] = JSValueMakeString(context, originJS);
> +    }

Consider using HashSet::copyToVector and using only the uint counter for more readability.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list