[Webkit-unassigned] [Bug 87696] [FileAPI] Miss FileList test

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 29 05:50:13 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=87696





--- Comment #10 from Li Yin <li.yin at intel.com>  2012-05-29 05:50:13 PST ---
(In reply to comment #7)
> (From update of attachment 144477 [details])
change="onInputFileChange(this.files)">
> 
> Nit: name="file" and id="file" are not needed.
> 

Done

> > LayoutTests/fast/files/file-list-test.html:18
> > +    shouldBeTrue("files.item(0) instanceof File");
> 
> Also you can test files.item(0).name and files.item(1).name to check if the correct files are stored?
> 
> shouldBeEqualToString('files.item(0).name', 'resources/UTF8.txt');
> shouldBeEqualToString('files.item(1).name', 'resources/UTF8-2.txt');
> 

Done.
But it should be shouldBeEqualToString('files.item(0).name', 'UTF8.txt');
File.name is merely the name of the file, without path information :) 

> > LayoutTests/fast/files/file-list-test.html:20
> > +    finishJSTest();
> 
> You can remove this.

Done

Thanks for your review.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list