[Webkit-unassigned] [Bug 59863] Incomplete repaint with box-shadow and padding when Javascript updates document

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 24 08:33:13 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=59863





--- Comment #21 from Simon Fraser (smfr) <simon.fraser at apple.com>  2012-05-24 08:32:17 PST ---
(From update of attachment 143767)
View in context: https://bugs.webkit.org/attachment.cgi?id=143767&action=review

> LayoutTests/ChangeLog:3
> +        Incomplete repaint with box-shadow and padding when Javascript updates document

"when Javascript updates document" is too vague. The bug title and change log should be changed to be more specific (what's being updated?)

> LayoutTests/fast/repaint/box-shadow-inset-repaint.html:14
> +		document.getElementById('container').innerHTML = "<div style='width:100px; height:100px; background-color:green'></div>";

I suspect the bug could be reproduced just by changing style, rather than setting innerHTML. This would result in a cleaner test case.

> Source/WebCore/rendering/RenderObject.cpp:1446
> +        LayoutUnit borderWidth = max<LayoutUnit>(-outlineStyle->outlineOffset(), max<LayoutUnit>(borderRight, max<LayoutUnit>(valueForLength(style()->borderTopRightRadius().width(), boxWidth, v), valueForLength(style()->borderBottomRightRadius().width(), boxWidth, v)))) + max<LayoutUnit>(ow, shadowRight) - insetShadowRight;

This line is incredibly hard to read. Maybe break it somehow, or use local variables.

> Source/WebCore/rendering/style/RenderStyle.cpp:1178
> +void RenderStyle::getShadowInsetExtent(const ShadowData* shadow, LayoutUnit &top, LayoutUnit &right, LayoutUnit &bottom, LayoutUnit &left) const
> +{

FractionalLayoutBoxExtent was added in 118076. Perhaps that should be used here.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list