[Webkit-unassigned] [Bug 84936] [chromium] Compute highlight for touch targets

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 22 19:33:36 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=84936





--- Comment #35 from Alexandre Elias <aelias at chromium.org>  2012-05-22 19:32:39 PST ---
(In reply to comment #33)
> > Source/WebKit/chromium/src/WebHighlight.cpp:73
> > +        for (size_t i = 0; i < newquads.size(); i++) {
> 
> I don't understand the purpose of this. If you need a Path can't you get one from WebCore directly instead of this hocus pocus code?

I had a chat offline with Tien-Ren about this.  First, I think we want the WebCore part to return rects because it's not guaranteed that the highlight rect generation will always support them (personally I think it's overkill and we may want to strip out Path support at some point).

But I think you have a point.  As Tien-Ren mentioned above, I think we should rename "repaintContainerHighlightQuads()" to "hitRectContainerQuads()" as ultimately what we want to highlight is the hit rect area of the element.  Moreover, this function will be usable in the future for the touch event quick-reject feature that we've been discussing.  Then, we can move the bulk of the hocus pocus -- the clipping for overflow: hidden elements -- into WebCore, since that logic matches the "hit rect" concept.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list