[Webkit-unassigned] [Bug 87113] [GTK] Add inspector API to WebKit2 GTK+

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 22 08:20:09 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=87113





--- Comment #4 from Carlos Garcia Campos <cgarcia at igalia.com>  2012-05-22 08:19:13 PST ---
(In reply to comment #3)
> (From update of attachment 143263 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=143263&action=review
> 
> Looks great. Couple nits below, but in general I really like the new API.

Thanks!, and sorry for the typos :-(

> > Source/WebKit2/UIProcess/API/gtk/WebKitWebInspector.cpp:150
> > +     * WebKitWebInspector::bring-to-front:
> 
> Perhaps this should be called "raise" to match "gdk_window_raise" or "present" to match "gtk_window_present"

Well, this depends on the implementation, for example, if the inspector is attached in a browser tab, bring-to-front is not just raise or present the window, but also make the tab active.

> > Source/WebKit2/UIProcess/API/gtk/WebKitWebInspector.cpp:224
> > +     * Emitted when the inspector is requested to be detached from the window
> > +     * where it currently is. The inspector is detached when the inspector page
> 
> Perhaps better phrased: "Emitted when the #WebKitWebInspector is requesting to be detached from the window it is currently attached to."

Indeed.

> > Source/WebKit2/UIProcess/API/gtk/WebKitWebInspector.cpp:340
> > + * Returns: the URI that is currently being inspected.
> 
> Can this be %NULL? If so, it would be good to mention it.

I think it's about:blank, but I'll check it.

> > Source/WebKit2/UIProcess/API/gtk/tests/TestInspector.cpp:351
> > +    CustomInspectorTest::add("WebKitWebInspector", "custom", testInspectorCustom);
> 
> This could probably be more specific about what it's testing. Perhaps "manual-attach-detach"

Ok.

> > Source/WebKit2/UIProcess/API/gtk/tests/TestInspector.cpp:352
> > +    CustomInspectorTest::add("WebKitWebInspector", "inspector-window-destroyed", testInspectorWindowDestroyed);
> 
> Perhaps "containing-window-destroyed" ?

containing window might be the inspected window when the inspector is attached, inspector window always refers to the external window that contains the inspector. This is testing the case when the external custom window, which not known by wk, is destroyed.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list