[Webkit-unassigned] [Bug 86874] New: IndexedDB: Rename IDBFactory.getDatabaseNames() to webkitGetDatabaseNames()

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 18 11:13:07 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86874

           Summary: IndexedDB: Rename IDBFactory.getDatabaseNames() to
                    webkitGetDatabaseNames()
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: WebCore Misc.
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: jsbell at chromium.org


The function is non-standard; while proposed, and with some interest from other implementers, it will not be in V1 of the IDB spec. 

While the overall IDB implementation in WebKit is currently prefixed, when we drop the prefix we do not want to introduce a non-prefixed non-standard member.

The patch probably as simple as:

- [CallWith=ScriptExecutionContext] IDBRequest getDatabaseNames();
+ [CallWith=ScriptExecutionContext, ImplementedAs=continueFunction] IDBRequest getDatabaseNames();

... plus test updates.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list