[Webkit-unassigned] [Bug 86649] New: isStartOfDocument and isEndOfDocument are poorly named

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 16 10:17:10 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86649

           Summary: isStartOfDocument and isEndOfDocument are poorly named
           Product: WebKit
           Version: 528+ (Nightly build)
          Platform: Unspecified
        OS/Version: Unspecified
            Status: NEW
          Severity: Normal
          Priority: P2
         Component: HTML Editing
        AssignedTo: webkit-unassigned at lists.webkit.org
        ReportedBy: rniwa at webkit.org
                CC: xji at chromium.org, mnaganov at chromium.org,
                    enrica at apple.com, leviw at chromium.org


bool isStartOfDocument(const VisiblePosition &p)
{
    return p.isNotNull() && p.previous().isNull();
}

bool isEndOfDocument(const VisiblePosition &p)
{
    return p.isNotNull() && p.next().isNull();
}

These functions are extremely poorly named. They don't check whether we're at the end of a document at all. They check whether we're at an editing boundary or not.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list