[Webkit-unassigned] [Bug 86426] Refactor SVG parts of Node::addEventListener/removeEventListener

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon May 14 19:03:39 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86426





--- Comment #1 from Rob Buis <rwlbuis at gmail.com>  2012-05-14 19:02:43 PST ---
Benefits of this approach:

- code in Node::addEventListener/removeEventListener is easier to read
- SVG parts can be hosted in svg/, much more intuitive
- no SVG includes in Node.cpp
- SVGElement() checks not needed anymore, since it is called from SVGElement.

Drawback is losing the static on tryAddEventListener/tryRemoveEventListener, not sure that would lead to performance loss though.

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list