[Webkit-unassigned] [Bug 86052] Split MediaPlayer::enterFullscreen into 2 separate functions

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu May 10 14:47:06 PDT 2012


https://bugs.webkit.org/show_bug.cgi?id=86052





--- Comment #5 from Min Qin <qinmin at chromium.org>  2012-05-10 14:46:10 PST ---
(In reply to comment #3)
> (From update of attachment 141074 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=141074&action=review
> 
> Looks good.
> 
> > Source/WebCore/ChangeLog:9
> > +        not do the same. And ios does not need the return value.
> 
> This has nothing to do with iOS, it was a general design issue.
> 
> > Source/WebKit/chromium/ChangeLog:12
> > +        It is confusing that enterFullscreen returns a boolean while exitFullscreen does
> > +        not do the same. And ios does not need the return value.
> > +        So remove the return value on enterFullscreen and make a seperate canEnterFullscreen()
> > +        function for android.
> > +        No behavior change, just refactoring.
> 
> You don't have to copy the text in each ChangeLog. The description is supposed to be related to the part including the ChangeLog (so in this case only about the Chromium changes).
> 
> > Source/WebKit/chromium/src/WebMediaPlayerClientImpl.cpp:359
> > +    if (m_webMediaPlayer)
> > +        return m_webMediaPlayer->canEnterFullscreen();
> > +    return false;
> 
> This could simply be written
> return m_webMediaPlayer && m_webMediaPlayer->canEnterFullscreen();

Done, changed it in the new patch

-- 
Configure bugmail: https://bugs.webkit.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.



More information about the webkit-unassigned mailing list